Supported Software

Operating Systems:

In an effort to provide a secure environment for our entire campus, we at CIT ask you to make sure you are currently using Windows 7 with all current software updates running Forefront Security when on campus. For Macintosh systems OS X 10.6 or higher is required with current software updates.

Software:

CIT offers software installation support from many Technical Support Professionals and will make a best effort to support questions for legally licensed, current versions of software to the best of our abilities. If you require support beyond our capabilities, you may need to purchase support from the software vender when appropriate.

Certain software that is known to be a source of system instability or contain spyware may need to be removed, especially if it is interfering in accomplishing the mission and goals of the college.